Jump to content

Photo

Fallout New Vegas – Fix Crash, Freezing, FPS Improve, NPC Slowdown, Mouse & Audio

- - - - -

  • Please log in to reply
5 replies to this topic

#1
Zayltsin

Zayltsin

    Apprentice

  • Allies
  • 91 posts


Users Awards
Please note, ALL information here is taken from the internet when trying to fix my game crashing

Fallout 3 New Vegas freezing & random freezes mid game, BSOD errors

Random freezes including BSOD errors can occur on certain multi core hardware environments due to incompatibilities with the game engine. You can try to avert these issues by limiting the game to use only two cores.

1. Open fallout.ini file in My Documents\My Games\FalloutNV with a text editor such as Notepad.
2. Look for the string bUseThreadedAI=0
3. Change it to bUseThreadedAI=1
4. Add another line beneath the above, iNumHWThreads=2
5. Save and close this file.
6. Repeat steps 2-5 for fallout_default.ini file in installation dir (default C:\Program Files (x86)\Bethesda Softworks\Fallout New Vegas)

Improve FPS, fix NPC slowdown, stuttering issues and increase framerate

I’ve got to say, this is an awesome fix and a godsend for those who are plagued with performance problems. Download and place the dx9.dll file as directed in instructions below and you may notice a significant performance increase with your Fallout New Vegas installation:

1. Download dx9.dll file from http://www.newvegasn...le.php?id=34778
2. Place file in ../steamapps/common/fallout new vegas (or wherever your falloutNV.exe is located)
3. Restart steam and the game. Game will now use Directx 9 Render Path instead of the backward computability DX9 API with DX10


This is also known to resolve some crash at launch issues with Fallout New Vegas.

Fix Jerky framerate issues, low FPS in Fallout New Vegas

Sometimes, particularly if you are using low end video hardware, you might find the game to be lagging in performance with stuttering and jerky frame rates. If you encounter this issue, try setting the water multisampling setting to low. I’ve found this to be killing lower end GPU and disabling this gave a noticeable performance boost.

Fix New Vegas mouse acceleration issues

I don’t know about you but I find the sudden mouse accelration annoying as hell. I’m not sure if this is a feature or a bug but if you want to disable it, follow the steps below:

1. Open FalloutPrefs.ini located inside My Documents\My Games\FalloutNV with a text editor.
2. Find the [Controls] section in this file.
3. Add the following lines to this section: fForegroundMouseAccelBase=0
fForegroundMouseAccelTop=0
fForegroundMouseBase=0
fForegroundMouseMult=0

Save and close the file (it’s assumed that this file is not read only – if it is, remove the read only attribute from file properties). Restart the game and mouse acceleration issues should hopefully be resolved. Repeat steps 1-3 for Fallout_default.ini located inside Steam\steamapps\common\fallout new vegas\ folder.

Fallout New Vegas crash after intro video

1. Download dx9.dll file from http://www.newvegasn...le.php?id=34778
2. Place the file inside your game' installation directory.
3. Restart the game.

If the above still does not fix your crash and launch, try running the game in windowed mode.

Fallout 3 New Vegas crash to desktop at intro or launch, black screen issues, audio issues

Above can happen if you have FFDShow codecs installed on your machine. Fallout 3 engine seems to have incompatibilities with these and is known to cause crashes as well as audio issues. You have to either uninstall the codecs from your system or add fallout3.exe to FFDShow audio and video decoders exceptions list.

1. Launch the ffdshow video decoder configuration window. You may access this through the start menu. If you have installed any codec packs, check the start menu entries of those. If you can’t find it on the start menu, right click the ffdshow video decoder (red) icon that appears on the taskbar when a supported video file is playing, and select ‘ffdshow video decoder’ option from the menu.
ffdshow_icon
2. Tick the ‘Dont use ffdshow in’ checkbox if not already checked
3. Press the edit button that is next to the text field. A new dialog box will pop up. Press the Add button. The ‘Add incompatible executable file’ dialog box will be displayed. Browse to the Fallout New Vegas installation directory and locate the main game exe file. Select it and press open. Close all dialog boxes currently open by pressing ok.
(OR you can simply type falloutnv.exe at the end of the text field next to ‘Dont use ffdshow in’ checkbox)
4. Repeat steps 2-3 in ffdshow audio decoder configuration (the blue icon in taskbar) window as well. It is important that you add fallout3.exe to both ffdshow audio and video decoder’s exceptions list.

This is a bug that’s been there since Fallout 3. We posted a separate article on how to fix this issue back in 2008, which you may find here.

New Vegas audio issues, lagging, stuttering or noisy audio

First of all, try the FFDShow fix (above) if you are having issues with New Vegas audio. If the problem persists, you can try the following:

* Disable surround sound output in your computers sound properties. Try to use Sterero speaker setup.
* Lower your sound card’s audio sampling rate to at least 48000hz (a screenshot and detailed steps on how to do this may be found in this article)
* Try running the game in Windowed Mode. Strange as it may sound, this seems to fix lagging audio for some.
* Update your sound card’s drivers.

Update your graphics drivers and DirectX

Again, this is pretty basic stuff buy many people seem to ignore this – always update your video card drivers to the latest build before running the game. Update your video card’s drivers – if latest drivers do not work, try downloading and installing latest beta drivers (do this at your own risk).

* ATI Drivers: Download the latest ATI Catalyst drivers from this link: http://game.amd.com/...s_catalyst.aspx
* NVIDIA Drivers: Download latest official NVIDIA drivers from this link: http://www.nvidia.co...aspx?lang=en-us
* Beta Drivers: Check here http://downloads.guru3d.com/

As for DirectX, you may download the latest monthly runtime from this location.

Problems Saving


This category is about problems with quicksave, autosave, and general saving for the game. This REALLY gets on people's nerves since they keep on losing all their data. Note that there ARE patches being released by the company so apply those patches BEFORE even attempting any of these fixes. You may find that the patch will solve the problem for you and it's better to use a legitimate fix rather than tweaks when it comes to something as important as your saved data.

"The game won't save, or my saves are overwritten, quicksave and autosave do not work, or I am having issues saving the game"

Unfortunately, Fallout: New Vegas is plagued with save issues. The fix is very annoying as well, so my suggestion is simple;

Do NORMAL, manual saves instead of QUICK SAVES for the time being until a patch is released. To speed this up, do the following--

1. Hit the ~ key
2. Type save "savefile1" and hit enter
3. When you need to save again, hit the ~ key like before, then hit the "up" arrow key to bring up the previously typed in save command. You can overwrite or rename the save file.
4. To load your file, hit the ~ key and type in load "savefile1"

"How Can I Recover My Saved Data From QuickSave / AutoSave / Etc?"

1. Locate the save files folder -- My Documents\My Games\FalloutNV\Saves
2. Find files that have a *.bak extension. If you cannot see extensions, enable them through these steps.
3. Rename the files with a .bak extension to something without the .bak extension (i.e. "autosave.fos.bak" to "autosave.fos" and then rename your old "autosave.fos" to autosave_old.fos", as they .bak may have your newer data).

"There Are No Game Save Files! How Can I Find Them / Fix This?"

1. Navigate to your Fallout.ini in the FalloutNV folder and set it to NOT Read-Only
2. Open the file and search for SLocalSavePath using CTRL+F (find option)
3. Look at the path it has listed to make sure there is an actual save folder (i.e. SLocalSavePath=Saves\ ). If it isn't present, make the folder yourself, otherwise the save files are located there!

"How Can I Fix The .BAK Save File Issue to Prevent Incorrect Save Overwriting?"

Some people are having luck with this method, while others are not. Be sure to back up your save files regardless before doing this.

1. Follow the steps above and load the Fallout.ini
2. Make the following change in the file:

CHANGE iSaveGameBackupCount=1 to iSaveGameBackupCount=0

Again, make sure to do a manual backup of the save files! And only do this if the latest patch isn't working for you!

"Is There Anything Else to Help Fix Saving the Game?"

Yes. I keep talking about files being "Read Only", but it may be that your entire SAVE FOLDER is "Read-Only".

1. Navigate to your Fallout Save folder and Right Click it -> Properties -> Uncheck "Read-Only".

Why it's set to "Read-Only" on some PC's, I do not know. But hopefully your game will be able to save now.

Edit: updated with save fixes.

Edited by Zayltsin, 27 October 2010 - 09:45 PM.

  • 0

#2
_echo

_echo

    Blade

  • Ambassadors
  • 1,231 posts


Users Awards
Anything about crashing any time you save? And I mean ANY saving causing crashing.
  • 0

#3
vometia

vometia

    Ambassador

  • Ambassadors
  • 958 posts


Users Awards
The mouse adjustment is an absolute must have IMHO: my hand was actually starting to hurt after just a day's worth of playing. I'll try out the threaded AI today. :dizzy:
  • 0

#4
Zayltsin

Zayltsin

    Apprentice

  • Allies
  • 91 posts


Users Awards

Anything about crashing any time you save? And I mean ANY saving causing crashing.


I did a search for you and found some info on it, I've added it to my original post.

Edited by Zayltsin, 27 October 2010 - 09:45 PM.

  • 0

#5
_echo

_echo

    Blade

  • Ambassadors
  • 1,231 posts


Users Awards
Unfortunately that didn't help. Thanks for taking the time to look into it, and at least you found something that may help others.
  • 0

#6
Vouivre

Vouivre

    Disciple

  • Allies
  • 443 posts


Users Awards
I found an interesting little thing with the ini tweak involving multicore processor pc's. at least somehow for me, the ini in the games folder did not want to play nice by saving. So, I deleted it, changed the default and put it back into the folder, "tested" by changing the 1 to 0 and then back and it saved fine. Now It shouldn't crash like before. Awesome finds and thanks!
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users