ZuTheSkunk

[FNV] Broken AI upon reload

I have a problem with a custom creature.

 

The creature is scripted to walk in a predetermined pattern, stopping briefly on specific spots throughout its patrol. In the event it sees the player, it's supposed to enter a "charge" AI package that forces it to reach the player at all costs. If the creature loses sight of the player for 3 seconds, it ceases charge and resumes its patrol. If the creature reaches the player, the player will blow up.

 

Now, when I startup the game, everything works fine up until getting blown up for the first time. After that, very weird stuff starts happening.

 

First off, when I use the COC console command to enter the cell, the creature is present at a different spot than intended. Second, it just doesn't behave properly. It has difficulty moving, it's stuck facing a specific direction, and seems to be able to only move forward. And sometimes, instead of moving normally, it ends up repeatedly teleporting, a few feet at a time.

 

One weird thing I noticed is that for some reason, I receive 55 XP upon reload. I have no idea why, but I suspect it might have something to do with the problem.

 

I've been trying to find the source of the problem for 5 hours, with no results. If I can't find a solution to this, I will have to abandon the project, because it completely nukes the idea I had.

 

Please help?

Edited by ZuTheSkunk
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now