TigerCubofPNW

[SKY]Custom Armor Not Appearing

It's that guy again with more questions....

Okay, thanks to the lovely folks here I managed (after an excruciating battle) to make the armor I wanted. Imagine my elation when I could look at in in NifSkope and see it just as it was meant to be.

Creation Kit, well, that's another issue. I added it using the Armor Addon and I got the Big Red Triangle and Exclamation Point of Failure.

Since it looks fine in Nifskope, it SHOULD work, so hopefully this won't be too hard. I went through two tutorials on prepping the armor for CK. I have added the armor _0 and _1 NIFs to a folder under the meshes folder and I put the DDS in a folder under the Textures. Nifskope can make sense of it, but not CK.

So, what things should I be looking for? I am assuming this is something I need to do yet in Nifskope. Frankly, this part of the CK baffles me. I used someone else's mesh to make a different armor and it worked fine. The NIF file didn't even point to the right DDS files but it mysteriously works. So, with that much inconsistency, I don't even know where to start.

I get this armor into the game and I shan't bother folks for at least a few weeks!

0

Share this post


Link to post
Share on other sites

I have a detailed tutorial here on how to add armor to the CK, but unfortunately due to the site upgrades, the tutorial module is offline.

 

There's a couple of things that could cause that issue. First of all, just try to refresh (F5). Sometimes the CK won't read the nif right away and this will force it. If it still doesn't come up then something is wrong with the nif itself (possibly just bad shader options) and would need a closer look.

0

Share this post


Link to post
Share on other sites

I have a detailed tutorial here on how to add armor to the CK, but unfortunately due to the site upgrades, the tutorial module is offline.

 

There's a couple of things that could cause that issue. First of all, just try to refresh (F5). Sometimes the CK won't read the nif right away and this will force it. If it still doesn't come up then something is wrong with the nif itself (possibly just bad shader options) and would need a closer look.

I have tried the F5 thing, tried saving and loading CK again and again. And it's just my luck about that tutorial. I've read some of it before but I couldn't really use it because I couldn't get Blender to work. I finally get Blender to work and now the tutorial is lost in the void. I don't suppose you have a PDF copy or anything?

I'm sure I'm doing something wrong. Going by the tutorial on the TESNexus wiki, I was able to follow all the steps to the letter except for the "FIx Dismembered Weights" step which it insists is necessary but then describes every part of it as "If you want to do this" and "You can also" which makes it all sound optional. The armor piece I am using is torso only, so I am not using any of the other body parts.

Another tutorial didn't have that step. They suggested I copy the BSLshader stuff from another mesh. Maybe I should do that?

I have concerns that I messed something up in Blender, but I keep telling myself that if the armor looks correct in Nifskope it should be fine, just needs some settings tweaked.

Related to all this is a question you can probably answer. Why is that when I call up some armors, especially vanilla armors, in Nifskope they have a body with them but others, especially many custom armors, have no bodies with them? The tutorials all seem to suggest it should have a body with it.

Anyway, thanks for the help.

0

Share this post


Link to post
Share on other sites

Another tutorial didn't have that step. They suggested I copy the BSLshader stuff from another mesh. Maybe I should do that?

This is what I also recommend in my tutorial (sorry, no I don't have a pdf of it). However, there could still be things wrong with it. Things like having Vertex Colors set to yes in the NiTriShapeData and missing the SLSF_2_Vertex_Colors flag, or vice versa. Or having BS Num UV Sets set incorrectly (4097 for armor, 1 for skin), or missing the SLSF_1_Skinned flag (I've done that lol). It's hard to say. If you can upload it somewhere or PM it to me I can look closer at it.

 

Why is that when I call up some armors, especially vanilla armors, in Nifskope they have a body with them but others, especially many custom armors, have no bodies with them?

It depends how you want to set up your armor. If you're using the typical SBP_32_Body partition for your armor, you need to include a body in your mesh as well, because the game replaces everything you're wearing with the new mesh. No body in the mesh = no body.

You can use any of the unused partitions for your armor, that way it won't replace what you're wearing and won't need to replace the body.

0

Share this post


Link to post
Share on other sites

Thank you for taking the time to respond to me. I don't want to drag you through having to basically write a new tutorial for me here. I think I'm just screwed for now. There are too many things which don't make sense, which aren't working the way the tutorials say. I delete the skeletons in Blender, then at the end import the new skeleton which shows up but I get an error about something not being a NINODE. I go into Nifskope and I suddenly have another body floating below the armor that wasn't there in Blender. The NUM UV Sets show up as zero. When I delete the NINODE Scene root, the body for the armor disappears. And so on. I was hoping that, having actually made the armor look right I could go the final step, but it looks like until your tutorial comes back online, I'm just screwed. With luck, there's something in there that will make sense of all this.

But really and sincerely, thank you for trying to help.

0

Share this post


Link to post
Share on other sites

I have part 5 of Hana's tutorial downloaded. It's the part that deals with NifSkope.

I'll look around and see if I have the rest of it.

Edit: Ok attachment didn't work

Edited by Kisuke
attachment didn't work - i don't like this new reason for edit thing =/
0

Share this post


Link to post
Share on other sites

I have part 5 of Hana's tutorial downloaded. It's the part that deals with NifSkope.

I'll look around and see if I have the rest of it.

Hana's_Armor_Tutorial.7z

That's very kind of you. Unfortunately, that link tells me I can't access it

0

Share this post


Link to post
Share on other sites

Maybe the attachments don't work yet. The site is having some issues at the moment. =( I'll try sending it in a pm but that'll probably be the same deal.

0

Share this post


Link to post
Share on other sites

Maybe the attachments don't work yet. The site is having some issues at the moment. =( I'll try sending it in a pm but that'll probably be the same deal.

Much appreciated. I'm poking at it some more, but if it isn't one thing it's another. Now the BS Properties are greyed out.

0

Share this post


Link to post
Share on other sites

How far did you get when you noticed the BS properties greyed out?

The very first step after exporting from Blender is to change the User Version and User Version 2 back to Skyrim values of 12 and 83. This ensures all the proper options for Skyrim meshes are available.

0

Share this post


Link to post
Share on other sites

How far did you get when you noticed the BS properties greyed out?

The very first step after exporting from Blender is to change the User Version and User Version 2 back to Skyrim values of 12 and 83. This ensures all the proper options for Skyrim meshes are available.

Yeah, dunno what happened there. I did the export again and the properties came back.

So, thanks to you for creating such a great tutorial and thanks to Kisuke for hooking me up with a copy of part of it, progress has been made. I hope you will indulge me with a few more issues.

One, just to be sure, in your tutorial you call it "Num UV Sets" but in my NIFskope it's called "BS NUM UV SETS". I assume that is just a syntax change in one of the Nifskope edits.

It seems to me that since I am just making a skirt, and therefore only using one part of the body, I should only have two NifTriShapes when I export--one for the body and one for the armor. I always seem to wind up with three, which makes me worry that the parenting thing in Blender didn't work. And does it matter what is higher up in the NINode tree?

The one piece of the TESnexus wiki I don't get is, in Blender, fixing dismemberment weights. It says it's necessary, but then it goes on to talk about how you can "choose" to move things around if you want. It doesn't say anything about anything that HAS to be done. That is really the only part of the Blender export process that isn't going according to that tutorial. And I only mention it because of the issue I am having. I just feel something has to be wrong in the export, since I follow your nice and very clear tutorial to the letter about preparing the armor in NIFSkope for Skyrim. Also, I've done comparisons in NIfSkope between my NIF and the NIF of another custom armor someone did that I know works. The only difference is that in their armor, in their body, they have "Has Normals" as yes, contrary to yours and everyone else's tutorials.

In the Armor Add On, I select the armor and in addition to it not recognizing the texture for the armor (it shows it in black, even though it looks fine in NIfskope) the body looks like a Salvador Dali painting, as shown in the attached image.

I would honestly give up and stop pestering you nice folks, but it seems every time I try I get a little further and that the end is near. Again, I really appreciate all the input and help. And I promise I do Google things before coming here, but sometimes an expert has to be asked. So.... Thoughts?

blenderissue02.jpg

1

Share this post


Link to post
Share on other sites

I don't mind the questions, I'm here to help. Hopefully other people will learn from it as well. :)

One, just to be sure, in your tutorial you call it "Num UV Sets" but in my NIFskope it's called "BS NUM UV SETS". I assume that is just a syntax change in one of the Nifskope edits.

Yes, its the same thing. To be clear, my tutorial is fairly old (from 2012). Even I do things slightly differently now and I should probably update it at some point and that version of Nifskope is outdated as well. I'll also be writing one in line with the updated versions of Blender - 2.7+. As is though, the process does work and should suit your purpose.

It seems to me that since I am just making a skirt, and therefore only using one part of the body, I should only have two NifTriShapes when I export--one for the body and one for the armor.

Yes you should only have 2 NiTriShapes. According to your picture, I'd say SLIM PUSHUP is the body, and CuirassTrooper is the skirt, making "pp" the miscellaneous NiTriShape you're talking about. What do you see when you highlight it? If it's nothing, just delete it (right click > block > remove branch), no need to keep it if it's nothing.

 

So let's move on to the picture and the all kinds of wrong there. What you're seeing is most likely from a "dirty" skeleton when you rigged it in Blender. My Part 4 talks about that before exporting, I'll quote it here for you....

Step 5: Rigging and Export
----------------------------

1. Re-open Blender and the .blend file. In Object mode, select all models. Import another instance of the malebody_0.nif, this time with Import Skeleton Only + Parent Selected checked.

2. Make sure the skeleton is 'clean'. Select just the skeleton and look at the name. If it's anything other than malebody_0.nif then it's not clean. Close Blender again (without saving) and wait a minute or two and try again.

5_2_blender.thumb.jpg.5edaf2722faba0e174
 

5_2a_blender.thumb.jpg.c9f2646cc74a672b9

3. Select A twice to select everything. Export with these settings.

blenderexport.thumb.jpg.8a012c80ec3821c4

(Also, change the Max Bones to 60 for clean partitions - the box to the right of Export Skin Partition)

It could possibly be the weight painting, in which case I would suggest you delete all your vertex groups and redo the Bone Weight Copy script again. (Yes, there's a lot of trial and error with Blender).

 

As for the skin texture, it looks like you gave it the texture of astridbody.dds. No need to do that. Give it the normal femalebody_1.dds textures. For the skirt, the CK either cannot find the texture in the location you pointed it to, or as mentioned before, there's confusion in the nif regarding vertex colours options. Another thing is it might have flipped normals. All these things will look fine in Nifskope because it renders quite differently than the game does.

 

Hopefully some of this will help, and we'll get your on your way to creating armor. :)

1

Share this post


Link to post
Share on other sites

I don't mind the questions, I'm here to help. Hopefully other people will learn from it as well. :)

You may come to regret saying that... :)

Okay, I don't know if this is the "root" of the problem, but you have something with the dirty skeleton thing. I suspected this part of the process was going pear-shaped. But it's much worse and far more confusing than it seems in those helpful graphics.

So let's go back, all the way back tot he beginning. I import the armor and everything looks normal until it's time to delete the skeleton, or "scene root." Now, to this point, I've been ignoring this weirdness, assuring myself that the little bone thingies (highlighted in pink) were this evil skeleton doohickey. However, as you can see, when highlighting them, they are not labeled "scene root." And that is confusing. Does that indicate a problem? If they aren't labeled Scene Root, should they not be deleted?


blenderissue03.thumb.jpg.32d69c7929946fc

So, that's happening. When I import the body, Blender behaves and the little bone-like thingies are labeled "Scene root" and so that's all fine. Then it comes time to add in the skeleton and things go very badly. I get an error that says, "Cannot import skeleton: root is not a ninode" which I can find no info on in Google. The skeleton does import, as a dirty skeleton, and just to really tweak my nose it's labeled "Scene Root 00". I tried the exit and reload thing a few times without success. (Also, even though I save the .blend file, it loses all my texture and material data, which I assume is one of Blender's cute little quirks.)

I figured something was wonky with the body. I went back to the original, Skyrimmed it in Nifskope, same problem. I tried a different body, same exact sequence of events.

Finally, there is a button on my import screen, "Import Bone priorities" I haven't seen referenced anywhere and don't know what setting it should be.

blenderissue04.thumb.jpg.2dda0b5024276fd



Once again, your time and patience are appreciated.

ETA: I have bypassed the effed up body issue. Still need to figure it out and all, but the bigger issue is the lack of texture. I have checked, double checked and triple checked. The path for the textures is identical to the path in other bodies/armor that work fine. So, what else would cause the texture to appear in Nifskope and not in Creation kit?

 

Edited by TigerCubofPNW
New info
1

Share this post


Link to post
Share on other sites

Yes, the pink doohickeys should always be deleted on first import. Here's another exerpt from my tutorial that will help;

Step 1: Import the Mesh
-------------------------

1. Import your 'Skyrim ready' (torso_0.nif) armor into Blender using these settings.

 blenderimport.thumb.jpg.3808016adf954696

2. Highlight just the skeleton object in the render window and Delete it (X).

3. Select the armor object in the render window. Click ALT+P to Clear Parent.

4. Delete the armature modifier.
5. Delete everything in Vertex Groups using the Delete button. Click Delete until everything is gone.

6. Add Material and Textures the same way as any other mesh. See this tutorial for more details.

Do this for all pieces of armor or body that you import. This will make sure everything is clean and ready to be re-rigged at the end when you import the final skeleton. Don't worry about what they're called, this is the skeleton. And never change the name when importing your final skeleton.

Also check the linked tutorial about material and textures. You should not be losing the information in your .blend file.

1

Share this post


Link to post
Share on other sites

Yes, the pink doohickeys should always be deleted on first import. Here's another exerpt from my tutorial that will help;

 

Do this for all pieces of armor or body that you import. This will make sure everything is clean and ready to be re-rigged at the end when you import the final skeleton. Don't worry about what they're called, this is the skeleton. And never change the name when importing your final skeleton.

Also check the linked tutorial about material and textures. You should not be losing the information in your .blend file.

I can already see a bunch of things not included in the NexusWiki tutorial. As to the graphic, I am mostly sure those are the settings I use, though, during import. However, I shall report back with (I hope) success.

ETA:  Sigh.... Sooo CLOSE. Damn, I was sure this was going to be the last round. *shakes fists at the heavens*

So, you were right about the dirty skeletons and that was a battle. But at long last, I was able to get a clean skeleton and my armor no longer looks like it's worn by Mr. Fantastic. Also, thanks to that tutorial you pointed me to, my meshes happily stay attached to my armor now in my blender saves. I was sure, so damn sure, that was what was causing my invisible texture issue.

Alas... My meshes are just black shadows. Now, as one can see from my first picture of the distorted mesh, at some point in this mess CK did in some way feel like recognizing the meshes I put in. Also, I have been playing with changing textures for armors and they have all showed up fine in CK. So I know my method for adding textures isn't at fault and I know that I know how to add textures. I mean, I basically took a simple piece of armor, slapped a vanilla texture on it, saved it into the very same folder where my new armor is and it worked fine. The path for the texture cannot be the issue.

What I don't know is why CK won't recognize them. They look fine in Nifskope. A comparison between working NIF files and my effed up files in NSk shows zero difference. Well, the Consistency Flag on my mesh shows up as Mutable where the working one shows Static, but changing the flag to match does no good.

Several searches from Google reveal nothing. I am sure there is yet SOMEthing in Blender that isn't right, but what or why or how I have no idea. In UV/Edit mode, the texture sits right where it should under the armor vertices. I switched it from ORCO to UV. Everything that I know to do for the textures in Blender has been done.

So, once again, I am stuck and begging for help. As I said, I could walk away if I didn't keep inching forward.





 

Edited by TigerCubofPNW
Update
1

Share this post


Link to post
Share on other sites

Send me your mesh as it is now. I can't keep guessing, I need to look at it. :)

1

Share this post


Link to post
Share on other sites

Okay, Hanaisse has found the error and so I figured I would share it with the class. I know it bugs me when I am looking for a solution to my coding problem and I find someone who had the exact same issue post about it but then no solution to the issue is shown.

Oh, and by the way, Hanaisse is awesome. Patient, helpful and brilliant. Couldn't ask for a better Blenderologist as a teacher!!!

So, as stated earlier in the thread, the dirty skeleton was the issue with the weird stretchy body. Hanaisse's instructions are very good on that. I will  just add that I found, for me, there was something actually wrong in the body I was using. I started over with a fresh body and that did the trick.

As to the texture issue, it was a Vertex Color Problem. Two pieces of info were in conflict. In the NITriShapeData blocks, the vertex color was set to No but on the BSLightingShaderProperty the flag for SLSF_2_Vertex_Color (under Shader Flags 2) was checked. Unchecking that was the fix.

And now, I have graduated from novice to apprentice Mesh Maker. :)

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now